Вопрос по информатике:
Составьте программу, которая заполняет массив a[1..8] случайными целыми числами в диапазоне от 1 до 10 и выводит на экран количество элементов с четными значениями и сумму элементов массива с нечетными значениями.
- 05.12.2015 12:24
- Информатика
- remove_red_eye 15776
- thumb_up 19
Ответы и объяснения 1
a:array [1..8] of integer;
i,summ,n:integer;
begin
randomize;
for i:=1 to 8 do begin
a[i]:=random(1,10);
write(a[i], ' ');
end;
n:=0;
summ:=0;
for i:=1 to 8 do
if a[i] mod 2=0 then
n:=n+1
else
summ:=summ+a[i];
writeln('');
writeln('Количество четных элементов ',n);
writeln('Сумма нечетных ',summ);
end.
- 06.12.2015 19:10
- thumb_up 20
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.