Вопрос по информатике:
Составить программу для вычесления площади и периметра треугольника(известны все три стороны) при двух условиях: если треугольник прямоугольный и если нет, то через формулу герона. В Паскале нужна программа
- 19.06.2016 09:02
- Информатика
- remove_red_eye 11519
- thumb_up 7
Ответы и объяснения 1
Program zadanie;
var a, b, c, s, p, pp:real;
begin
writeln('Введите сторону a');
read(a);
writeln('Введите сторону b');
read(b);
writeln('Введите сторону c');
read(c);
p:=a+b+c;
pp:=p/2;
if (sqr(a)=sqr(b)+sqr(c)) then
begin
writeln('Прямоугольный треугольник с гипотенузой a');
s:=1/2*b*c;
writeln('Площадь = ',s);
end;
if (sqr(b)=sqr(a)+sqr(c)) then
begin
writeln('Прямоугольный треугольник с гипотенузой b');
s:=1/2*a*c;
writeln('Площадь = ',s);
end;
if (sqr(c)=sqr(b)+sqr(a)) then
begin
writeln('Прямоугольный треугольник с гипотенузой c');
s:=1/2*b*a;
writeln('Площадь = ',s);
end
else
begin
writeln('Непрямоугольный треугольник');
s:=sqrt(pp*(pp-a)*(pp-b)*(pp-c));
writeln('Площадь = ',s);
end;
writeln('Периметр = ',p);
end.
- 21.06.2016 00:34
- thumb_up 30
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.