Вопрос по информатике:
Помогите.Информатика 9 класс.Составьте программу которая формирует массив из 16 случайных целых чисел от -20 до 20 и находит элемент с нулевым значением
- 19.05.2018 15:05
- Информатика
- remove_red_eye 931
- thumb_up 52
Ответы и объяснения 1
var
a: array [1..16] of integer;
i: integer; b: boolean;
begin
randomize;
for i := 1 to 16 do a[i] := random(-20, 20);
for i := 1 to 16 do
if a[i] = 0 then begin
if b then write(', ');
write(i, '-й ');
b := true;
end;
if b then writeln('элемент(ы) равен(ны) нулю') else writeln('В массиве нету элементов, равных нулю.');
end.
- 20.05.2018 07:36
- thumb_up 26
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.