Вопрос по информатике:
Написать программу на языке Pascal
Палиндромом называется строка, которая одинаково читается как слева направо, так и
справа налево. Рассмотрим все натуральные числа, запись которых в десятичной системе
счисления является палиндромом (при этом запись не начинается с нуля). Например, числа
121 и 1331 являются палиндромами, а число 123 — нет. По данному числу N найдите N-e в
порядке возрастания число-палиндром.
Программа получает на вход одно натуральное число N, не превосходящее 100 000.
Программа должна вывести одно натуральное число — N-е в порядке возрастания
число-палиндром.
Пример входных и выходных данных
Ввод 20
Вывод 111
- 18.10.2017 19:07
- Информатика
- remove_red_eye 1518
- thumb_up 8
Ответы и объяснения 1
Var
s: string;
n,m: integer;
begin
readln(n);
if (n <= 9) then write(n)
else if (n <= 9 + 9) then
begin
s := inttostr(n - 9);
write(s + s);
end
else if (n <= 9 + 9 + 90) then
begin
s := inttostr(n - 9 -9 + 10 -1);
m:=s.Length-1;
write(s + s[m:0:-1]);
end
else if (n <= 9 + 9 + 90 + 90) then
begin
s := inttostr(n - 9 - 9 + 90 + 10 - 1);
write(s + s[::-1]);
end
else if (n <= 9 + 9 + 90 + 90 + 900) then
begin
s := inttostr(n - 9 - 9 - 90 - 90 + 100 - 1);
m:=s.Length-1;
write(s + s[m:0:-1]);
end
else if (n <= 9 + 9 + 90 + 90 + 900 + 900) then
begin
s := inttostr(n - 9 - 9 - 90 - 90 - 900 + 100 - 1);
write(s + s[::-1]);
end
else if (n <= 9 + 9 + 90 + 90 + 900 + 900 + 9000) then
begin
s := inttostr(n - 9 - 9 - 90 - 90 - 900 - 900 + 1000 - 1);
m:=s.Length-1;
write(s + s[m:0:-1]);
end
else if (n <= 9 + 9 + 90 + 90 + 900 + 900 + 9000 + 9000) then
begin
s := inttostr(n - 9 - 9 - 90 - 90 - 900 - 900 - 9000 + 1000 - 1 );
write(s + s[::-1]);
end
else
begin
s := inttostr(n - 9 - 9 - 90 - 90 - 900 - 900 - 9000 - 9000 + 10000 - 1);
m:=s.Length-1;
write(s + s[m:0:-1]);
end
end.
- 19.10.2017 19:00
- thumb_up 37
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.