Вопрос по информатике:
Помогите, пожалуйста, составить программу в ПАскаль абс и блок-схему:
В заданной целочисленной квадратной матрице заменить нулями минимальные элементы каждой строки
- 21.08.2018 15:16
- Информатика
- remove_red_eye 17961
- thumb_up 24
Ответы и объяснения 1
//PascalABC.NET 3.2 сборка 1318
Const
n=3;
m=2;
Var
ma:array[1..n,1..m] of integer;
i,j,min:integer;
begin
for i:=1 to n do
begin
min:=integer.MaxValue;
for j:=1 to m do
begin
readln(ma[i,j]);
if ma[i,j]
for j:=1 to m do
if ma[i,j]=min then ma[i,j]:=0;
end;
writeln('Final matrix:');
for i:=1 to n do
begin
for j:=1 to m do
write(ma[i,j]:4);
writeln;
end;
end.
- 22.08.2018 14:19
- thumb_up 27
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.