Вопрос по информатике:
Дан массив А(m), меньше или равно 20. Ввести на печать сумму элементов массива, Если она превосходит число 50, В противном случае вывести в печать исходный массив.
Написать программу , только прошу с интернета не брать, там программы не работают, свою программу я написала, но что-то выдаёт не так, помогите, пожалуйста.
- 17.11.2017 21:38
- Информатика
- remove_red_eye 11664
- thumb_up 9
Ответы и объяснения 1
Вот самый короткий способ с рандомным массивом, про ввод тут не совсем понятно
//PascalABC.Net 3.1.0.1200
begin
var a := ArrRandomInteger(ReadInteger('m ='), 1, 20);
var s := a.Sum;
if s > 50 then
writeln(s)
else
Println(a);
end.
вот переделанный ваш код
//PascalABC.Net 3.1.0.1200
Uses crt;
const
nmax = 20;
var
A: array[1..nmax] of integer;
I, m, s: integer;
Am, kon: text;
begin
Clrscr;
Assign(Am, 'Am.txt');
{раскоментировать для записи массива в файл}
{Rewrite(Am);
m := Random(nmax - 5) + 5;
for i := 1 to m do
Writeln(Am, Random(20));
Close(Am);
{считывание данных из файла}
Reset(Am);
s := 0;
m := 0;
while not eof(Am) do
begin
m := m + 1;
Readln(Am, A[m]);
s := s + A[m];
end;
Close(Am);
Assign(kon, 'kon.txt');
Rewrite(kon);
if s > 50 then
Writeln('Сумма элементов массива более 50 и равна: s=', s)
Else
begin
Writeln('Сумма элементов менее 50, вывод исходного массива');
for i := 1 to m do
begin
Writeln('A[', i, ']=', A[i], ' ');
Writeln(kon, 'A[', i, ']=', A[i], ' ');
end;
end;
Close(kon);
Readkey;
end.
- 18.11.2017 08:57
- thumb_up 31
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.