Вопрос по информатике:
Дан массив, состоящий из целых чисел. Напишите программу, которая подсчитывает количество положительных чисел среди элементов массива.
Входные данные
Сначала задано число N — количество элементов в массиве (1N10000). Далее через пробел записаны N чисел — элементы массива. Массив состоит из целых чисел.
Выходные данные
Необходимо единственное число - количество положительных элементов в массиве.
Java
- 25.01.2015 00:05
- Информатика
- remove_red_eye 4922
- thumb_up 46
Ответы и объяснения 1
public static void main(String[] args) {
int[] mas;
Scanner in = new Scanner(System.in);
System.out.print("N=");
int N=in.nextInt();
int polozh=0;
mas = new int[N];
for(int i=0;i
if(mas[i]>0)
polozh++;
}
System.out.println("Всего положительных чисел:"+polozh);
}
- 26.01.2015 06:28
- thumb_up 47
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.