Вопрос по информатике:
Определите значение переменной а после выполнения данного алгоритма: а:= 3 b:= -1 b:= 9+а*b а:= (b*b)/(b/a) В ответе укажите одно число — значение переменной а
- 08.05.2017 19:06
- Информатика
- remove_red_eye 17242
- thumb_up 14
Ответы и объяснения 2
var a,b: Real;
begin
a:=3;
b:=-1;
b:=9+a*b;
a:=(b*b)/(b/a);
writeln(a);
end.
2. Запустим программу в программе Pascal и в консоли увидем полученное значение переменной a (18.0);
Ответ: a=18.0
- 09.05.2017 08:45
- thumb_up 40
b:=-1 - вместо b будем ставить -1
b:=9+a*b - ставим вместо a число 3, а вместо b число -1,
получим b=9+3*(-1)=9-3=6
- это НОВОЕ значение переменной b!
Теперь вместо a ставим 3, а вместо b ставим число 6!
a:=(b*b)/(b/a) - ставим справа вместо a число 3, а вместо b число 6,
получим a=(6*6)/(6/3)=36/2=18
Ответ: a=18
- 01.01.1970 00:00
- thumb_up 14
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.