Вопрос по информатике:
Задача Полет
Известно время вылета самолёта НН часов и ММ минут ,а также продолжительность полёта ( НР часов и МР минут)
Напишите программу,которая определяет время прибытия самолёта в аэропорт Назначение в формате "чс:мм"
- 14.03.2016 10:14
- Информатика
- remove_red_eye 19722
- thumb_up 8
Ответы и объяснения 1
Var
h0, m0, h1, m1, h2, m2: integer;
begin
readln(h0, m0, h1, m1);
m0 += h0 * 60;
m1 += h1 * 60;
m2 := m0 + m1;
h2 := (m2 div 60) mod 24;
m2 := (m1 + m0) mod 60;
h0 := h2 div 10;
h1 := h2 mod 10;
m0 := m2 div 10;
m1 := m2 mod 10;
write(h0, h1, ':', m0, m1);
end.
- 15.03.2016 09:55
- thumb_up 2
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.