Вопрос по информатике:
Написать программу в паскале . вводим два числа. компьютер должен вывести квадратное уравнение,корнями которого являются эти два числа. (использоват теорему виета)
- 10.10.2017 07:04
- Информатика
- remove_red_eye 15093
- thumb_up 32
Ответы и объяснения 1
Var x1,x2,p,b:real;
begin
readln(x1,x2);{Вводим два числа}
p:=x1+x2;{Вычисляем значение коэффициента при х}
b:=x1*x2;{Вычисляем значение свободного слагаемого}
if p>0 then{Проверка на знак полученных значений и вывод уравнения, как проще сделать со знаком, увы не знаю}
begin
if b>0 then
writeln('x^2-',p,'x+',b,'=0')
else
writeln('x^2-',p,'x-',abs(b),'=0');
end
else
begin
if b>0 then
writeln('x^2+',abs(p),'x+',b,'=0')
else
writeln('x^2+',abs(p),'x-',abs(b),'=0');
end;
end.
- 11.10.2017 07:15
- thumb_up 10
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.