Вопрос по информатике:
НАЙДИТЕ ОШИБКУ В КОДЕ!
задание:Написать программу, которая бы рассчитывала значение выражения по формуле: (ln|cos(x)|)/(ln(1+x^2).
Мой код:
Program formula;
var
x:integer;
y:real;
begin
write('vvedute x ');
readln(x);
y:=(ln(abs(cos(x))))/ln(1+cos(x*x));
writeln('y=',y:5:2);
end.
почему то выдаёт ошибку. что не так?
- 26.03.2015 23:25
- Информатика
- remove_red_eye 17323
- thumb_up 31
Ответы и объяснения 1
Program formula;
var
x:integer;
p,y:real;
begin
Write('vvedute x0 ->');
Readln(x);
if x=0 then Writeln('x=0 nedopustimo')
else begin
p:= abs(cos(x));
if p=0 then Writeln('ln(0) v 4islitele')
else begin
y:=ln(p)/ln(1+sqr(x*x));
Writeln('y=',y:5:2)
end
end
end.
- 27.03.2015 15:56
- thumb_up 27
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.