Вопрос по информатике:
Дан массив А, состоящий из 6 элементов. Вывести элементы массива. Изменить порядок следования элементов массива на обратный, вывести инвертированный массив.
Помогите, пожалуйста, составить программу в паскале!!!
Вот, например, я начала.
Program z10;
VAR
p, i: Integer;
x: Array [1..6] of integer;
Begin
For i:=1 to 6 Do
begin
p:=a[i];
А как дальше поменять местами остальные элементы??
- 26.03.2015 23:58
- Информатика
- remove_red_eye 19775
- thumb_up 32
Ответы и объяснения 1
1)
просто выводим элементы наооборот
program gt;
var a:array[1..6]of longint;
n,i:integer;
begin
read(n);
for i:=1 to n do
begin
read(a[i]);
end;
for i:=6 downto 1 do
begin
write(a[i],' ');
end;
end.
2)
добавляем дополнительный массив b
program gt;
var a,b:array[1..6]of longint;
n,k,i:integer;
begin
read(n);
k:=7;
for i:=1 to n do
begin
read(a[i]);
k:=k-1;
b[k]:=a[i];
end;
for i:=1 to 6 do
begin
write(b[i],' ');
end;
end.
3)
Изменяем элементы массива без дополнительных элементов
Program z10;
VAR
p, i: Integer;
x: Array [1..6] of integer;
Begin
For i:=1 to 3 Do
begin
p:=a[i];
a[i]:=a[6-i+1];
a[6-i+1]:=p;
end;
for i:=1 to 6 do
begin
write(a[i],' ');
end;
end.
- 27.03.2015 13:20
- thumb_up 8
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.