Вопрос по информатике:
Напишите программу, которая заменяет в символьной строке все буквы a на буквы b (латинские, строчные).
В Си
- 23.03.2018 07:45
- Информатика
- remove_red_eye 10655
- thumb_up 51
Ответы и объяснения 1
#include
#include
#include
#include
//Замена
#define a 'a'
#define b 'b'
//Размер строки
#define n 255
int main(){
setlocale(LC_ALL, "rus");
char s[n];
printf("\n >> Введите строку:\n << ");
fgets(s, n, stdin);
for (int i = 0; i < strlen(s); i++)
if (s[i] == a)
s[i] = b;
printf("\n >> Результат:\n >> ");
fputs(s, stdout);
system("pause>>void");
return 0;
}
- 24.03.2018 22:59
- thumb_up 27
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.