Вопрос по информатике:
Написать программу, которая в последовательности натуральных чисел определяет сумму чисел, кратных 2 и оканчивающихся на 4. Программа получает на вход количество чисел в последовательности, а затем сами числа. последовательности всегда имеется число, кратное 2 и оканчивающееся на 4. Количество чисел не превышает 200. Введенные числа по модулю не превышает 400. Программа должна вывести одно число: сумму чисел, кратных 2 и оканчивающихся на 4.
Пример:
Входные данные: Выходные:
5 52
8
4
14
16
34
- 06.09.2016 00:20
- Информатика
- remove_red_eye 6238
- thumb_up 40
Ответы и объяснения 1
Var
i, n, num, sum: integer;
begin
num:=0;
read(n);
for i:=1 to n do
begin
read(num);
if (num mod 2 = 0) and (num mod 10 = 4) then
sum:=sum+num;
end;
writeln(sum);
end.
- 06.09.2016 10:39
- thumb_up 40
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.