Вопрос по информатике:
Даны три геометрические фигуры: 1 ) прямоугольник со сторонами a = 2, b = 3
2 ) круг радиуса R = 5
3 ) треугольник со сторонами x = 3, y = 4, z = 5. Напишите программу (на алгоритмическом языке Паскаль) для расчета площади фигуры, выбранной пользователем. Выбор осуществляется путем ввода с клавиатуры пользователем соответствующего номера фигуры. Составьте блок-схему алгоритма.
- 10.04.2018 16:50
- Информатика
- remove_red_eye 11013
- thumb_up 20
Ответы и объяснения 1
var n:integer; a,b,r,x,y,z,p,s:real;
begin
writeln('Введите номер фигуры: 1) прямоугольник; 2) круг; 3) треугольник:');
readln(n);
case n of
1: begin
write('a, b: '); readln(a,b);
s:=a*b;
writeln('s = ',s);
end;
2: begin
write('r = '); readln(r);
s:=pi*r*r;
writeln('s = ',s);
end;
3: begin
write('x, y, z: '); readln(x,y,z);
p:=(x+y+z)/2; s:=sqrt(p*(p-x)*(p-y)*(p-z)); writeln('s = ',s);
end;
else writeln('Ошибка ввода');
end;
end.
Пример:
Введите номер фигуры: 1) прямоугольник; 2) круг; 3) треугольник:
3
x, y, z: 3 4 5
s = 6
- 11.04.2018 12:17
- thumb_up 12
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.