Вопрос по информатике:
Помогите пожалуйста!!! Паскаль!!!
Структура цикла:
for i:=c to x do
begin
......
end
i*-переменная(принято принимать ее за i или j) Важно: i может принимать только натуральные значения!
c*-число, которое присваивается i в начале цикла.
x*-число(переменная), достигнув которого, цикл завершит работу.
Дано вещественное число A и целое число N (N> 0). Найти A в степени N: AN = A•A•...•A (числа A перемножаются N раз).
Входные данные: ввести вещественное число А (-5<=A<=5) и целое число N (1<=n<=10).
Выходные данные: вывести A в степени N с точностью до 4 цифр в дробной части.
Вещественное число это число типа Real!
- 17.07.2016 16:16
- Информатика
- remove_red_eye 11727
- thumb_up 21
Ответы и объяснения 1
Var n,i:integer; a,an:real;
begin
write('A = '); readln(a);
write('N = '); readln(n);
an:=1;
for i:=1 to n do an:=an*a;
writeln(a,'^',n,' = ',an:6:4);
end.
Пример:
A = 2.1
N = 4
2.1^4 = 19.4481
- 18.07.2016 00:22
- thumb_up 40
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.