Вопрос по информатике:
Напишите программу, которая ввод данных в одномерный целочисленный массив осуществляет посредством цикла WHILE...DO, а вывод – REPEAT...UNTIL (в скобках указана размерность массива)
1. подсчитать произведение неотрицательных элементов в двухмерном массиве 6 × 3;
- 23.05.2015 05:14
- Информатика
- remove_red_eye 14326
- thumb_up 49
Ответы и объяснения 1
var
i, j, p: integer;
a: array[1..6, 1..3] of integer;
begin
p := 1;
i := 1;
j := 1;
while i <= 6 do
begin
while j <= 3 do
begin
write('a[',i,'][',j,']=');
readln(a[i,j]);
j := j + 1;
end;
i := i + 1;
end;
i := 1;
j := 1;
repeat
repeat
if a[i,j] >= 0 then
p := p * a[i,j];
j := j + 1;
until j > 3;
i := i + 1;
until i > 6;
writeln('произведение неотрицательных элементов: ',p);
end.
- 24.05.2015 18:12
- thumb_up 17
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.