Вопрос по информатике:
Составить программу вычисления стоимости покупки с учётом скидки. Скидка 3% предоставляется в том случае, если сумма покупки больше 500 рублей, 5% - если сумма больше 1000 рублей. В результате вывести итоговую стоимость покупки и размер предоставленной скидки.
- 13.09.2018 01:24
- Информатика
- remove_red_eye 18526
- thumb_up 19
Ответы и объяснения 1
Var s:integer;
begin
write('Стоимость покупки = '); readln(s);
if s>1000
then writeln('Скидка 5% (',s*0.05,' руб.), необходимо заплатить ',s*0.95)
else if s>500
then writeln('Скидка 3% (',s*0.03,' руб.), необходимо заплатить ',s*0.97)
else writeln('Скидки нет');
end.
Пример:
Стоимость покупки = 600
Скидка 3% (18 руб.), необходимо заплатить 582
- 14.09.2018 04:05
- thumb_up 44
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.