Вопрос по информатике:
Написать программу (в паскаль) по закупке товаров в магазине на определённую сумму денег, не превышающую заданное количество денег.
ВХОДНЫЕ ДАННЫЕ: С клавиатуры вводится сумма, на которую предполагается произвести покупки. Затем вводятся цена и количество товара №1, товара №2 и т.д. до тех пор пока не будет исчерпана сумма денег.
- 06.01.2017 22:33
- Информатика
- remove_red_eye 6641
- thumb_up 5
Ответы и объяснения 2
Uses crt;
var s:integer;
b,y,a:real;
begin
write('Введите сумму денег, на которую собираетесь произвести покупки: ');
read(a);
while a>0 do begin
s:=s+1;
write('Товар №',s,': ');
read(b);
write('Введите количество: ');
read(y);
a:=a-(b*y);
end;
end.
- 07.01.2017 02:45
- thumb_up 29
Uses crt;
var
sum,x,itog: real;
i,y: integer;
begin
i:=1;
itog:=0;
write ('Start summa: ');
readln (sum);
while (itog
write ('¹',i,': ');
i:=i+1;
readln (x);
write ('Kol-vo: ');
readln (y);
itog:=itog+y*x;
end;
if (itog>sum) then
writeln ('Itog: ',itog-y*x)
else
writeln ('Itog: ',itog);
end.
- 08.01.2017 17:56
- thumb_up 3
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.