Вопрос по информатике:
Напишите программу, которая в последовательности целых чисел определяет минимальное ОТРИЦАТЕЛЬНОЕ число, кратное 6. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется ОТРИЦАТЕЛЬНОЕ число, кратное 6. плиззз дам мноого балов
- 16.12.2017 12:04
- Информатика
- remove_red_eye 12922
- thumb_up 44
Ответы и объяснения 1
// Pascal
var n, i, a, min:integer;
begin
min:=666666;
readln(n); //ввод количества чисел
// раз мы знаем количество чисел, то используем цикл for
for i:=1 to n do begin
readln(a);
//проверка введенного числа на кратность 6, отрицательность и минимальность
if (a<0)and (a mod 6 =0) and (a
writeln(min); //вывод минимального отрицательного кратного 6
end.
- 17.12.2017 07:49
- thumb_up 6
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.