Вопрос по информатике:
Написать программу на алгоритмическом языке программирования для вычисления минимального отрицательного числа и максимального положительного числа из 15 чисел введенных с клавиатуры(Язык с++)
- 02.04.2016 08:00
- Информатика
- remove_red_eye 5698
- thumb_up 18
Ответы и объяснения 1
#include
using namespace std;
int main()
{
int x, Max, Min;
x=Max=Min=0;
for (int i=1;i<=15;++i) {
cin >> x;
if (x > Max) Max=x;
if (x < Min) Min=x;
}
cout << "Максимальное положительное число " << Max << " Минимальное отрицательное число " << Min << endl;
if (Max == 0 or Min == 0) cout << "Число 0 означает что такого значения нет" << endl;
}
- 03.04.2016 09:46
- thumb_up 27
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.