Вопрос по информатике:
Паскаль
Написать программу для нахождения суммы большего и меньшего из трех чисел. Указание: для решения задачи использовать подпрограммы вычисления минимального и максимального для двух чисел.
Пример
на входе: 45 72 24
на выходе: 96
- 19.12.2016 06:42
- Информатика
- remove_red_eye 11998
- thumb_up 44
Ответы и объяснения 1
a, b, c: integer;
function min_3(const a, b, c: integer): integer;
var
local_min: integer;
begin
if (a < b) then
local_min := a
else
local_min := b;
if (c < local_min) then
local_min := c;
Result := local_min
end;
function max_3(const a, b, c: integer): integer;
var
local_max: integer;
begin
if (a >= b) then
local_max := a
else
local_max := b;
if (c > local_max) then
local_max := c;
Result := local_max;
end;
begin
writeln('Введите a, b, c -> ');
readln(a, b, c);
writeln('Результат: ', min_3(a, b, c) + max_3(a, b, c), '.');
end.
- 20.12.2016 17:57
- thumb_up 6
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.