Вопрос по информатике:
Написать программу while ..do
Ввести с клавиатуры 10 чисел. Если квадрат числа меньше 100, напечатать число и его квадрат.
- 20.05.2018 03:20
- Информатика
- remove_red_eye 10227
- thumb_up 25
Ответы и объяснения 1
Одно из возможных решений. Также можно использовать массив, если это необходимо за условием.
const
n = 10;
var
i, number: integer;
begin
i := 1;
while (i <= n) do
begin
write('Введите ', i, '-ое число: ');
readln(number);
if sqr(number) < 100 then
writeln('Число: ', number, '. Квадрат числа: ', sqr(number), '.');
Inc(i);
end
end.
- 21.05.2018 04:17
- thumb_up 46
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.