Вопрос по информатике:
Составьте программу, выполняющую поиск минимального нечетного элемента в заданном целочисленном массиве из 50 элементов.Известно, что в массиве есть хотя бы один нечетный элемент.
- 06.09.2016 00:21
- Информатика
- remove_red_eye 9195
- thumb_up 27
Ответы и объяснения 1
Const
n = 50;
var
a: array[1..n] of integer;
i, min: integer;
begin
Randomize;
Writeln('Исходный массив');
min:=32767;
for i := 1 to n do
begin
a[i] := Random(99)+1;
Write(a[i]:3);
if ((a[i] mod 2)0) and (min>a[i]) then min:=a[i]
end;
Writeln;
Writeln('Минимальный нечетный элемент равен ',min)
end.
Тестовое решение:
Исходный массив
24 19 87 17 11 98 74 11 57 42 9 23 3 90 62 61 53 55 63 93 22 50 82 97 26 39 43 26 46 52 13 94 26 98 87 95 43 69 24 41 56 78 22 45 53 45 59 57 3 64
Минимальный нечетный элемент равен 3
- 07.09.2016 21:25
- thumb_up 25
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.