Вопрос по информатике:
Составить программу.
Дано натуральное число n. Подсчитать количество цифр этого числа.
- 01.01.2015 07:58
- Информатика
- remove_red_eye 2231
- thumb_up 46
Ответы и объяснения 2
Program chisla;
uses crt;
var a,b,c: integer;
begin
writeln('Введите натуральное число: ');
readln(a);
b:=a;
c:=0;
while b 0 do
begin
c:=c+1;
b:= b div 10;
end;
writeln('B числе ',a,' - ',c, ' цифр');
end.
- 02.01.2015 17:07
- thumb_up 10
Var
n: longint;
s: string;
k: byte;
begin
Write('Введите натуральное число '); Readln(n);
{ Преобразуем число к строке, убрав знак (мало ли...) }
Str(abs(n), s);
{ Выведем длину полученной строки }
Writeln('Количество цифр в числе равно ', Length(s))
end.
Тестовое решение:
Введите натуральное число 164275353
Количество цифр в числе равно 9
- 03.01.2015 00:51
- thumb_up 11
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.