Вопрос по информатике:
Написать программу в Pascal по 2 способам for и while.
Задание:Вывести на экран числа оканчивающаяся на 3 в промежутке от n до 150
- 16.03.2015 08:51
- Информатика
- remove_red_eye 16325
- thumb_up 46
Ответы и объяснения 2
var
n: integer;
begin
write('Введите начало диапазона (n): ');
readln(n);
while n < 150 do
begin
if n mod 10 = 3
then write(n, ' ');
n := n + 1; end;
end.
for:
var
n, i: integer;
begin
write('Введите начало диапазона (n): ');
readln(n);
for i := n to 150 do
if n mod 10 = 3
then write(i, ' ');
end.
- 18.03.2015 18:04
- thumb_up 21
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.