Вопрос по информатике:
Получив на вход число х, этот алгоритм печатает два числа К и R. Укажите наименьшее из таких чисел х, при вводе которых алгоритм печатает сначала 4, а потом 3.
var x, i, K, R, y: integer;
begin
readln(x);
K := 0; R := 9;
y := x mod 10;
while x > 0 do begin
K := K + 1;
if R > x mod 10 then
R := x mod 10;
x := x div 10
end;
R := y - R;
writeln(K); writeln(R)
end.
- 23.09.2015 10:11
- Информатика
- remove_red_eye 8345
- thumb_up 29
Ответы и объяснения 1
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.