Вопрос по информатике:
Написать программу, которая после ввода пользователем трёхзначного числа вычисляет сумму его цифр.
- 23.12.2017 02:24
- Информатика
- remove_red_eye 2910
- thumb_up 64
Ответы и объяснения 1
var a,a1,a2,a3 : integer;
begin
readln(a);
a1:=a div 100;
a2:=(a mod 100) div 10;
a3:=(a mod 100) mod 10;
writeln(a1+a2+a3);
end.
а - само число, а1-число сотен, а2-число десятков, а3-число единиц
- 23.12.2017 22:05
- thumb_up 37
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.