Вопрос по информатике:
Перед началом учебного года все школьники проходят медицинский осмотр, каждому измеряют рост и вес. Для каждого первоклассника необходимо также определить тип парты (по росту, всего 3 типа). Проведите медицинский осмотр 500 школьников.
Составьте программу, содержащую процедуру, отвечающую за измерение роста и веса, и функцию, отвечающую за определение типа парты первоклассника.
Шкала типа парт:
140<=
140-150
>=150
Программу составить в Pascal ABC
Помогите пжлста!
- 25.08.2018 15:20
- Информатика
- remove_red_eye 9633
- thumb_up 29
Ответы и объяснения 1
Procedure GetRV(var r, v: real; var Final: boolean);
{ Организует ввод и возвращает значения роста и веса.
Значение параметра Final=true - сигнал окончить ввод данных,
для чего вводят нули }
begin
Write('Введите рост (см) и вес (кг) ->');
Readln(r, v);
Final := ((r > 0) and (v > 0))
end;
function DefDesk(r: real): string;
begin
if r <= 140 then DefDesk := 'S'
else if r < 150 then DefDesk := 'M'
else DefDesk := 'L'
end;
var
rost, ves: real;
flag: boolean;
begin
repeat
GetRV(rost, ves, flag);
if flag then Writeln('Нужна парта типа ', DefDesk(rost))
until (not flag)
end.
Тестовое решение:
Введите рост (см) и вес (кг) ->135 31
Нужна парта типа S
Введите рост (см) и вес (кг) ->143 41
Нужна парта типа M
Введите рост (см) и вес (кг) ->151 48
Нужна парта типа L
Введите рост (см) и вес (кг) ->0 0
- 26.08.2018 10:13
- thumb_up 45
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.