Вопрос по информатике:
Напишите программу, которая в последовательности натуральных чисел определяет минимальное число, делящееся нацело на 7 . Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, делящееся нацело на 7.
Количество чисел не превышает 1000. Введеные числа не превышают 30 000.
программа должна вывести одно число - минимальное число, делящееся нацело на 7.
Завтра Гиа помогите!!!
- 10.10.2017 08:55
- Информатика
- remove_red_eye 10802
- thumb_up 39
Ответы и объяснения 1
Program fofgogjoj;
const n=1000;
var
a:array[1..n] of integer;
i,min:integer;
begin
randomize;
for i:=1 to n do
begin
a[i]:=random(30000);
end;
min:=a[1];
for i:=1 to n do begin
if ((a[i] div 7)=0) and (a[i]
end;
writeln('Минимальное число, делящееся на 7=',min);
end.
- 11.10.2017 17:08
- thumb_up 27
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.