Вопрос по информатике:
1.Составьте программу, выводящую на экран все двухзначные числа, у которых сумма цифр равна 8.
2.Составьте программу вычисления количества трёхзначных чисел палиндромов ( чисел, которые читаются одинаково слева направо и справа налево).
3.Найти двухзначные числа, которые делятся на сумму своих цифр
4.Составьте программу вывода количества трёхзначных чисел, у которых цифры упорядочены строго по убыванию.
РЕБЯТА СРОЧНО!!!!!!!!!!!
- 20.05.2018 12:43
- Информатика
- remove_red_eye 3344
- thumb_up 21
Ответы и объяснения 1
3)
program gt;
var i,j:integer;
begin
for i:=1 to 9 do
for j:=0 to 9 do
if((10*i+j)mod(i+j)=0)then writeln(i,j);
end.
4)program gt;
var a,b,c,t:integer;
begin
for a:=2 to 9 do
for b:=a-1 to 9 do
for c:=b-1 to 9 do
t:=t+1;
writeln(t);
end.
- 21.05.2018 12:39
- thumb_up 2
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.