Вопрос по информатике:
Найдите наибольший общий делитель двух чисел. Или для цикла (пока), или для цикла (до) в паскале.
- 13.12.2016 13:23
- Информатика
- remove_red_eye 2228
- thumb_up 6
Ответы и объяснения 1
Var a, b, answer: integer;
function gcd(m, n: integer): integer;
var modulo: integer;
begin
modulo := m mod n;
if modulo = 0 then gcd := n
else gcd := gcd (n, modulo) end;
begin
write('Введите 2 числа: '); readln(a, b);
answer := gcd(a, b);
writeln('Наибольший общий делитель: ', answer);
end.
- 14.12.2016 08:24
- thumb_up 48
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.