Вопрос по информатике:
Pascal ABC
Задача 1
составить программу которая запрашивает целое число не равное нулю сообщает положительное они или отрицательное и при этом положительное число уменьшает в 2 раза, отрицательные возводит в квадрат .
Задача 2
составить программу , которая определяет является ли введенное число нечетным и выводит на экран сообщение да или нет .
- 06.07.2016 20:11
- Информатика
- remove_red_eye 10503
- thumb_up 35
Ответы и объяснения 2
1.
Program ZADACHA;
Uses crt;
var a: integer;
Begin clrscr;
write('Введите целое число не равное нулю a = ');
readln(a);
writeln;
if a<0 then
Write('Число a отрицательное, результат = ', a*a)
else
Write('Число a положительное, результат = ', a/2);
End.
2.
Program CHETNOST;
Uses crt;
var a: integer;
Begin clrscr;
write('Введите целое число a = ');
readln(a);
writeln;
if (a mod 2) = 1 then
Write('Да')
else
Write('Нет');
End.
- 08.07.2016 22:14
- thumb_up 29
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.