Вопрос по информатике:
Вклад в банке составляет x рублей. Ежегодно он увеличивается на p процентов, после чего дробная часть копеек отбрасывается. Каждый год сумма вклада становится больше. Определите, через сколько лет вклад составит не менее y рублей. Программа получает на вход три натуральных числа: x, p, y и должна вывести одно целое число. ТОЛЬКО НА ПАСКАЛЕ
- 17.01.2016 21:59
- Информатика
- remove_red_eye 16727
- thumb_up 24
Ответы и объяснения 1
Var sum, required_sum, percent : real;
years : integer;
Begin
read(sum, percent, required_sum);
if percent > 1 then percent := percent / 100;
repeat
sum := trunc(100 * sum * (1 + percent)) / 100;
years := years + 1;
writeln(years, ' sum = ', sum);
until sum >= required_sum;
writeln(years);
End.
- 18.01.2016 12:17
- thumb_up 3
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.