Вопрос по информатике:
Паскаль АВС. Дана строка символов. Составьте программу которая подсчитывает, сколько в данной строке слов оканчивающихся на а. Все слова разделяются 1 пробелом и только русские буквы.
- 23.09.2018 17:22
- Информатика
- remove_red_eye 16600
- thumb_up 27
Ответы и объяснения 1
Var
s: string;
i, n: integer;
a: set of char;
begin
Writeln('Введите строку текста');
Readln(s);
n := 0;
a := ['А', 'а'];
for i := 1 to Length(s) do
if (s[i] = ' ') and (s[i - 1] in a) then n := n + 1;
if (s[i - 1] in a) then n := n + 1;
Writeln('Количество слов, оканчивающихся буквой "а", равно ', n)
end.
Тестовое решение:
Введите строку текста
А роза упала на лапу Азора
Количество слов, оканчивающихся буквой "а", равно 4
- 24.09.2018 22:16
- thumb_up 42
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.