Вопрос по информатике:
Помогите написать программу в Pascal, пожалуйста
Среди 8 положительных чисел найти такое, которое имеет наибольшую сумму цифр, используя функцию
- 12.12.2015 06:07
- Информатика
- remove_red_eye 15885
- thumb_up 35
Ответы и объяснения 1
function sum(n:integer):integer;
var s:integer;
begin
s:=0;
while n0 do
begin
s:=s+n mod 10;
n:=n div 10;
end;
sum:=s;
end;
begin
max:=0;
for i:=1 to 8 do
begin
write('a = ');
readln(a);
s:=sum(a);
if s>max then begin max:=s; amax:=a; end;
end;
writeln('В числе ',amax,' максимальная сумма цифр = ',max);
end.
Пример:
a = 405a = 120
a = 309
a = 671
a = 456
a = 215
a = 751
a =321
В числе 456 максимальная сумма цифр = 15
- 13.12.2015 07:24
- thumb_up 25
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.