Вопрос по информатике:
Задача в Pascal!!!!!!
Том Сойеру необходимо покрасить забор с двух сторон, который содержит N досок. Размеры каждой доски А * В (в метрах). На каждый квадратный метр доски расходуется С кг краски. Каждая банка содержит D кг. Помогите Тому Сойеру определить количество банок краски, которые ему потребуются для покраски забора.
Входные данные:
Во входном потоке в первой строке через пробел заданы пять целых чисел (N, A, B, C, D <= 1000).
Выходные данные:
Вывести единственное число.
Пример входного файла (input.txt):
10 1 1 2 3
- 11.11.2017 15:16
- Информатика
- remove_red_eye 1244
- thumb_up 42
Ответы и объяснения 1
Var
A, B, C, D, N, V, K, M: integer;
F: Text;
begin
Assign(f,'input.txt');
Reset(f);
Readln(N,A,B,C,D);
Close(f);
V := A * B * N;
if V mod C 0 then
K := V div C + 1
else
K := V div C;
if K mod D 0 then
M := K div D + 1
else
M := K div D;
writeln(M)
end.
Тестовое решение:
2
- 12.11.2017 05:41
- thumb_up 17
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.