Вопрос по информатике:
Составить программу которая создаёт массив случайных чисел, выводит его на экран и вычисляет сумму всех его элементов.
- 09.02.2018 17:36
- Информатика
- remove_red_eye 11021
- thumb_up 52
Ответы и объяснения 1
program jfe3;
const n=10; {Это будет кол-во элементов массива}
var a:array [1..n] of integer; i,s:integer;
begin
for i:=1 to n do begin
a[i]:=random(100); {элемент выбирается случайно от 0 до 100}
s:=s+a[i]; {Когда эл. присвоился, его значение плюсуется к общ сумме}
end;
for i:=1 to n do
writeln(a[i],' '); {показать сам массив}
writeln(s); {показать сумму}
readln; {чтобы окно сразу не закрывалось}
end.
Если есть вопросы по программе, пиши в личку. Если надо что-то еще - тоже =)
Удачи)
;- 09.02.2018 20:48
- thumb_up 26
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.