Вопрос по информатике:
Том Сойеру необходимо покрасить забор с двух сторон, который содержит N досок. Размеры каждой доски А * В (в метрах). На каждый квадратный метр доски расходуется С кг краски. Каждая банка содержит D кг. Помогите Тому Сойеру определить количество банок краски, которые ему потребуются для покраски забора.
Входные данные:
Во входном потоке в первой строке через пробел заданы пять целых чисел (N, A, B, C, D <= 1000).
Выходные данные:
Вывести единственное число.
Пример входного файла (input.txt):
10 1 1 2 3
Пример выходного файла (output.txt):
14
- 19.09.2018 05:15
- Информатика
- remove_red_eye 5594
- thumb_up 24
Ответы и объяснения 1
var
n, a, b, c, d: real;
begin
try
assign(input, 'input.txt');
assign(output, 'output.txt');
reset(input);
rewrite(output);
read(input, n, a, b, c, d);
write(output, trunc(a * b * 2 * n * c / d) + 1);
finally
try
close(input);
close(output);
except
end;
end;
end.
- 20.09.2018 18:43
- thumb_up 18
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.