Вопрос по информатике:
Напишите программу которая в последовательности натуральных чисел находит среднее арифметическое трехзначный чисел или сообщает,что таких чисел нет
- 15.01.2017 09:59
- Информатика
- remove_red_eye 2134
- thumb_up 14
Ответы и объяснения 1
Var
a,n,s: integer;
begin
//0 - условие окончания ввода последовательности
repeat
readln(a);
if (a>99) and (a<1000) then begin
s:=s+a;n:=n+1;
end;
until a = 0;
if n = 0 then writeln ('В последовательности 3-х значных нет')
else writeln('Среднее арифметическое 3-х значных чисел = ',s/n);
end.
Тест №1
1
5
234
123
5
0
Среднее арифметическое 3-х значных чисел = 178.5
Тест №2
3
5
5678
12
0
В последовательности 3-х значных нет
- 16.01.2017 06:34
- thumb_up 37
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.