Вопрос по информатике:
Срочно)))))
Найдите наименьшее натуральное число, у которого ровно 32 делителя (включая 1 и само число 32). Например, у числа 6 четыре делителя: 1, 2, 3, 6. В качестве ответа укажите одно натуральное число.
- 15.01.2017 10:40
- Информатика
- remove_red_eye 18585
- thumb_up 50
Ответы и объяснения 2
Внимание! Если программа не работает, обновите версию!
function KolDiv(n:integer):integer;
begin
Result:=0;
for var i:=2 to n div 2 do
if n mod i=0 then Result+=1
end;
begin
var n:=1;
while KolDiv(n)30 do n+=1; // 30 - это без 1 и самого числа
Writeln(n)
end.
Результат
840
- 17.01.2017 12:28
- thumb_up 34
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.