Вопрос по информатике:
написать программу на ПАСКАЛЕ: Дана матрица А, имеющая N строк и N столбцов. Сформируйте два одномерных массива. В один перешлите четные, а в другой -нечетные элементы матрицы. Выведите на экран все массивы.
ИЛИ
написать программу на ПАСКАЛЕ: Вычислить произведение n! до значения 1255534676756. Пожалуйста решите какую сможете.
- 18.06.2018 00:36
- Информатика
- remove_red_eye 7980
- thumb_up 25
Ответы и объяснения 1
Var
i,f:int64;
begin
f:=1;
i:=1;
while f<1255534676756 do
begin
f:=f*i;
writeln(i:2,' ',f);
i:=i+1
end
end.
Результат работы программы:
1 1
2 2
3 6
4 24
5 120
6 720
7 5040
8 40320
9 362880
10 3628800
11 39916800
12 479001600
13 6227020800
14 87178291200
15 1307674368000
- 18.06.2018 14:21
- thumb_up 31
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.