Вопрос по информатике:
Написать программу, которая проверяет, является ли введенная с клавиатуры строка двоичным числом. Помогите. На PASCAL
- 05.05.2017 10:53
- Информатика
- remove_red_eye 12315
- thumb_up 12
Ответы и объяснения 1
VAR
c: Char;
BEGIN
Assign(input, 'input.txt'); ReSet(input);
Read(c);
If (c '1') then begin Write('NO'); Exit; End;
While (not eoln(input)) do begin
Read(c);
If (c '0')and(c '1') then begin Write('NO'); Exit;
End;
END.
- 06.05.2017 18:04
- thumb_up 38
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.