Вопрос по информатике:
1.Что из вышеперечисленного не входит в алфавит языка Pascal?
А) латинские строчные и прописные буквы
Б) служебные слова
В) русские строчные и прописные буквы
Г) знак подчеркивания
2. В качестве имени переменных в языке Pascal нельзя использовать:
А) BR Б) OR В) WR Г) AR Д) DR
3. Служебное слово VAR в программе на языке Pascal фиксирует начало раздела программы, содержащего:
А) операторы
Б) список меток
В) описание сложных типов данных
Г) перечень констант
Д) описание переменных
4. Числа в языке Pascal различаются как:
А) натуральные и целые
Б) целые и вещественные
В) натуральные и вещественные
Г) целые и иррациональные
Д) целые и рациональные
5. Логический тип данных объявляется служебным словом:
А) boolean Б) logic В) char Г) string
6. Cтроковый тип данных объявляется служебным словом:
А) char Б) string В) integer Г) real
7. Операторы в программе на языке Pascal отделяются друг от друга:
А) апострофом Б) двоеточием В) пробелом Г) запятой Д) точкой с запятой
8. При записи оператора вывода на языке Pascal используется служебное слово:
А) WRITE Б) RESET В) READ Г) BEGIN Д) WHILE
9. При выполнении последовательности операторов
А: =2;
В: =4;
Х: =А mod В значение переменной Х равно:
А) 2 Б) 4 В) 6 Г) 8
10. Цикл с предусловием определяется служебным словом:
А) FOR Б) WHILE В) REPEAT Г) IF
11. В каком варианте неправильно записан оператор объявления переменных:
А) var f, g, d, t: integer; i, t: real
Б) var a, b: real; c: real
В) var i, g, max, min: real
Г) var a, b, c, d: integer; i, t, k: real
12. Какое составное условие надо использовать для того, чтобы определить входит ли число А в диапазон значений (4 ; 10]?
А) (A>=4) and (A<0)
Б) (A<=4) and (A>0)
В) (A>4) and (A<=10)
Г) (A>=4) or (A<0)
Д) (A>4) or (A<=10)
13. Дана программа:
Program T21;
Var X: Integer;
Begin
Readln(X);
If X MOD 5=0 Then Writeln(‘ДА’)
Else Writeln(‘НЕТ’)
End.
При каком значении X будет получен ответ “ДА”?
А) 7; Б) 14; В) 51; Г) 36; Д) 20.
14. Цикл в фрагменте программы
p: =2;
repeat
p: =p*0.1
until p<0.1;
будет исполнен:
А) 0 раз Б) 1 раз В) 2 раза Г) бесконечное число раз
15. Определите значения переменных s и i после выполнения фрагмента программы:
s: =0; i: =5;
while i>=0 do
begin
s: =s+1;
i: =i-1;
end;
А) s: = 6; i: = -1
Б) s: = 5; i: = 0
В) s: = 15; i: = 5
Г) s: = 15; i: = 0
- 15.12.2017 05:25
- Информатика
- remove_red_eye 16581
- thumb_up 18
Ответы и объяснения 1
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.