Вопрос по информатике:
А)Составьте программу ввода элементов массива а[1..8] с клавиатуры и вывода на экран элементов с отрицательными значениями.
б)составьте программу,которая заполняет массив b[1..8] случайными целыми числами в диапазоне от 1 до 10 и находит количество элементов с нечетными значениями.
- 18.10.2017 21:48
- Информатика
- remove_red_eye 12584
- thumb_up 35
Ответы и объяснения 1
А)
var a:array[1..8] of integer;
i:integer;
begin
for i:=1 to 8 do read(a[i]);
for i:=1 to 8 do if (a[i] <0) then writeln(a[i]);
end.
б)
var b:array[1..8] of integer;
i,c:integer;
begin
randomize;
for i:=1 to 8 do begin
b[i]:=random(10)+1;
if (b[i] mod 2=1) then inc(c);
end;
writeln(c);
end.
Не забывай отмечать лучший ответ!
- 20.10.2017 00:23
- thumb_up 10
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.