Вопрос по информатике:
Определить среди 3 введенных чисел(a,b,c) количество отрицательных и положительных.
Если больше положительных, то найти минимум из этих 3 чисел, а иначе найти максимум.(нужно нарисовать блок схему и написать программу в паскале)
- 23.03.2018 09:54
- Информатика
- remove_red_eye 9170
- thumb_up 29
Ответы и объяснения 1
Var a,b,c,m,k:integer;
begin
readln(a,b,c);
if a>0 then inc(k) else dec(k);
if b>0 then inc(k) else dec(k);
if c>0 then inc(k) else dec(k);
if k>0 then begin
if a if m>c then m:=c;
end else begin
if a>b then m:=a else m:=b;
if m
writeln(m);
end.
- 24.03.2018 23:26
- thumb_up 11
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.