Вопрос по информатике:
Напишите программу, которая в последовательности натуральных
чисел определяет сумму чисел, оканчивающихся на 3. Программа
получает на вход количество чисел в последовательности, а затем сами
числа. В последовательности всегда имеется число, оканчивающееся на 3.
Количество чисел не превышает 100. Введённые числа не превышают 300.
Программа должна вывести одно число – сумму чисел, оканчивающихся на 3.
- 14.08.2018 22:26
- Информатика
- remove_red_eye 10129
- thumb_up 79
Ответы и объяснения 2
Program n1;
Uses CRT;
Var s,i: integer;
begin
ClrScr;
Repeat
readln(i);
If (i mod 3=0)or(i mod 100=0) then s:=s+i;
until i=0;
writeln('Сумма =',s);
readln
end.
- 16.08.2018 03:09
- thumb_up 5
-Program n1;
-Uses CRT;
-Var s,i: integer;
-begin
-ClrScr;
-Repeat
-readln(i);
-If (i mod 3=0)or(i mod 100=0) then s:=s+i;
-until i=0;
-writeln('Сумма =',s);
-readln
-end.
Этой пойдёт в паскале
- 17.08.2018 01:59
- thumb_up 40
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.