Вопрос по информатике:
на паскале составить программу нахождения наибольшего общего делителя трех чисел , испол. след. формулу: НОД(А,В,С)=НОД(НОД(А,В),С)
- 10.03.2016 10:18
- Информатика
- remove_red_eye 17187
- thumb_up 33
Ответы и объяснения 1
function NOD (x,y:longint):longint;
begin
if x=0 then NOD:=y
else
if y=0 then NOD:=x
else
if x>y then NOD:=NOD(x mod y,y)
else
NOD:=NOD(x,y mod x);
end;
var
a,b,c:longint;
begin
read(a,b,c);
writeln('NOD (',a,',',b,',',c,') = ',NOD(NOD(a,b),c));
end.
- 11.03.2016 02:01
- thumb_up 26
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.