Вопрос по информатике:
Напишите программу, в результате выполнения которой первое введённое число уменьшается в три раза, если оно больше, чем третье, а третье становится разностью третьего и второго, если оно больше второго.
- 01.12.2017 21:15
- Информатика
- remove_red_eye 15856
- thumb_up 9
Ответы и объяснения 1
Var
number1, number2, number3 : real;
begin
write('Первое число: ');
readln(number1);
write('Второе число: ');
readln(number2);
write('Третье число: ');
readln(number3);
if (number1 > number3) then number1 := number1 / 3;
if (number3 > number2) then number3 := number3 - number2;
writeln('Вывод');
writeln('Первое число: ', number1);
writeln('Второе число: ', number2);
writeln('Третье число: ', number3);
end.
- 02.12.2017 16:19
- thumb_up 43
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.