Вопрос по информатике:
Напишите программу, которая в последовательности целых чисел находит среднее арифметическое чисел, кратных 9, или сообщает, что таких чисел нет. Программа получает на вход целые числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 – признак окончания ввода, не является членом последовательности). Количество чисел не превышает 100. Введённые числа по модулю не превышают 300. Программа должна вывести среднее арифметическое чисел, кратных 9, или вывести NO, если таких чисел в последовательности нет.
- 17.06.2018 23:48
- Информатика
- remove_red_eye 17296
- thumb_up 86
Ответы и объяснения 1
var
a, i, count, s: integer;
begin
repeat
if(i = 100) then break;
readln(a);
if(abs(a) > 300) then begin
writeln('Число по модулю не может быть > 300.');
continue
end
else if(a mod 9 = 0) and (a 0) then begin
inc(count);
s := s + a;
end;
if(a 0) then inc(i);
until(a = 0);
writeln('Среднее арифметическое: ', s / count);
end.
- 19.06.2018 03:36
- thumb_up 7
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.